Dren Serving Problem, Am I the Only One?

Home Forums General Archery Discussion Dren Serving Problem, Am I the Only One?

This topic contains 19 replies, has 13 contributors, and was last updated by buldog762000 buldog762000 7 years, 5 months ago.

Viewing 5 posts - 16 through 20 (of 20 total)
  • Author
    Posts
  • February 17, 2007 at 12:03 pm #509865 Back to Top REPORT
    jeff-k-in-il
    Jeff K in IL

    Age: 26
    Joined: 11/1/2005
    I cannot tell if there is seperation or not in those photos. I have no seperation problems on my Dren after 600 shots… [=}=]
    February 17, 2007 at 7:32 pm #509866 Back to Top REPORT
    tedd3
    Tedd3

    Joined: 2/3/2007
    Out of the box I had issues with the serving on my Drenalin and two years ago I also had the same concerns on my Switchback. It really didn’t matter to me because I end up replacing the Mathews strings with a Winner’s Choice. There is absolutely NO comparison in the servings.

    I’ve mentioned before that I love Mathews bows, but from my experience I’ll replace the strings every time.

    February 17, 2007 at 7:55 pm #509867 Back to Top REPORT
    gbbl-gbl
    GBBL GBL

    Joined: 11/26/2004
    Nothing at all on mine….over 1,000 shots :thumbup

    February 17, 2007 at 9:01 pm #509868 Back to Top REPORT



    Joined: 5/24/2004
    No wear on mine either. Just some discoloration.
    After 332 shots and 9 let downs.

    John

    February 17, 2007 at 10:29 pm #509869 Back to Top REPORT
    buldog762000
    buldog762000

    Joined: 1/14/2007
    I have very minor seperation on the same spot of the cable as circled in pic. I have shot it 2200+ times. And to think that last week I had no seperation at all.
Viewing 5 posts - 16 through 20 (of 20 total)